Downgrade iTunes from 12.7 to 12.6

UPDATE:
This proves to be a roundabout way of downgrading iTunes. Please see this post on installing an older version of iMovie which is a much faster, more reliable method. Just change “iMovie” to “iTunes” and it works the same.

We use iTunes to manage several iPads on our campus. We log in from our iMacs and purchase apps that then automatically download to our devices. Unfortunately, iTunes lost support for iOS app purchases in version 12.7 in the October of 2017. Any time we update MacOS, I’m anticipating that we’ll need to downgrade iTunes to 12.6.2 to regain this functionality.

Apple doesn’t make this easy. One needs to first delete the current iTunes app, swap out the iTunes Library.itl file and then install 12.6.2.

If your Mac doesn’t allow you to delete iTunes, you’ll need to turn off  System Integrity Protection to do so:

  1. Restart your Mac, holding down Command-R until you see the Apple logo
  2. Once the computer boots, under the Utilities menu, open Terminal.
  3. Turn off SIP by entering the command csrutil disable.
  4. Enter reboot to restart your Mac

Once restarted, you should be able to remove iTunes. You should be able to do so in Finder or in Terminal with . sudo rm -rf /Applications/iTunes.app.

Now, in Finder, visit ~/Music/iTunes/ folder and locate the file named “iTunes Library.itl” and move it somewhere safe as a backup.

Then open the “Previous iTunes Libraries” folder and find the most recent dated iTunes Library file (these are labeled by the last iTunes install date). Copy this file and paste it into the iTunes/ folder and rename it “iTunes Library.itl”. I ran into issues doing it this way once and just deleted the iTunes Library file altogether. iTunes just made a new one in the next step.

Now, download iTunes 12.6.2 here and install it.

You should now be able to run iTunes 12.6.2 with access to the iOS App Store.

Finally, go back and turn SIP back on:

  1. Restart your Mac, holding down Command-R until you see the Apple logo
  2. Once the computer boots, under the Utilities menu, open Terminal.
  3. Turn off SIP by entering the command csrutil enable.
  4. Enter reboot to restart your Mac

If this fails, check out this solution from here:

1.turn off SIP as noted above
2.Mac restart
3.Enter this Terminal code (OK to copy all/paste into Terminal)

sudo rm -rf /Library/Documentation/Applications/iTunes/Acknowledgements.rtf /Library/Documentation/iPod/Acknowledgements.rtf /Library/Frameworks/iTunesLibrary.framework/ /Applications/iTunes.app/ /System/Library/PrivateFrameworks/iTunesAccess.framework/ /System/Library/LaunchDaemons/com.apple.fpsd.plist /System/Library/PrivateFrameworks/CoreFP.framework/ /System/Library/PrivateFrameworks/CoreADI.framework/ /System/Library/LaunchDaemons/com.apple.adid.plist /System/Library/CoreServices/UAUPlugins/ADIUserAccountUpdater.bundle/ /System/Library/CoreServices/CoreTypes.bundle/Contents/Library/MobileDevices.bundle/ /System/Library/LaunchDaemons/com.apple.usbmuxd.plist /System/Library/PrivateFrameworks/AirTrafficHost.framework/ /System/Library/PrivateFrameworks/DeviceLink.framework/ /System/Library/PrivateFrameworks/MobileDevice.framework/ /System/Library/Extensions/AppleMobileDevice.kext/ /System/Library/Extensions/AppleUsbEthernetHost

4.install iTunes 12.6.2 & restore Your backup file 「 iTunes Library.itl 」
5.turn on 「 MAC SIP 」
6.Disable iTunes update – terminal code:
sudo softwareupdate --ignore iTunesXPatch

Thanks to OSXDaily and Apple Discussion guy Niel for tips.

Tracking Down Student Records after Permanently Storing Grades Improperly (PowerSchool)

In June, 2017, we stored grades for our secondary students, neglecting to exclude enrollments that were not active at the time. This means that if any student dropped a course for any reason and had received a grade in the grade book, that course would show up on a transcript with the grade that was current as of the drop date. We didn’t catch the error until the following October. So, we had to track down every high school enrollment that had been unenrolled, pretty much from the first week of second semester. Then we needed to check to see if there was a permanent grade stored for that enrollment and, if so, delete it from the database.

The hardest part was figuring out how to find the students in DDE. This is how we did it:

  1. In the CC table, select all records.
  2. SchoolID = 300 (Our High School)
  3. DateLeft < 06/01/2017  (The end of the semester was 06/07/2017)
  4. DateLeft > 01/10/2017   (The end of the first week of the semester)
  5. Course_Number < 898 (We have dozens of “Club” courses numbered 898-995)
    1. This whole process needs to be repeated to also select course Numbers > 999 to catch the rest of the non-club courses.
  6. *** Switch to the Students table ***
  7. Grade Level >= 9 (Get current HS Freshmen and above)
  8. Grade Level <=12 (Restrict to Seniors and below – exclude Graduates)
  9. Enroll_Status = 0 (Current students only)
  10. Match selection with CC table

Once we had this info, we ran transcript reports for the 35 or so students and checked to see if grades were showing up for dropped courses. Luckily, there were only a few for underclassmen that needed correcting and none of any significant consequence.